设为首页 | 收藏本站 | 每日归档
当前位置:ucbug游戏网 > 新闻中心 > 业界动态 >
关于星际管家加载剧情战役存盘加载失败的说明
作者:Jimmy来源:ucbug游戏网发布时间:2010-09-26 01:04

    很多人以为是星际管家的bug,到处投诉,其实我很无奈,只怪我错误的去做暴雪的辅助工具,以后再开发暴雪的工具,劝大家一定要慎重再慎重,否则吃力不讨好,还有一堆人指责。

       其实这是暴雪的不兼容再一次发威,大家没有看我在6.1博客里面写的吗?暴雪历来最喜欢的事情就是不兼容,这点和星际管家的作者正好相反,为了全兼容,星际管家不知设计了多少兼容体系,星际2目录选择,版本号判定,AI设定,地图识别,作弊全兼容,地图编辑算法设计,一切的一切都是为了2个字,“兼容”。不信大家可以看看,现在除了星际管家,全球那个星际2辅助工具,能说兼容0.2-1.1全部版本的?

     首先是录像格式,星际2就经过了0.2版本,0.3-0.10版本,0.11-0.14.1版本,0.16-0.18版本,0.19-1.0.3版本,1.1到未来,6次完全不兼容的大修改,要翻译这些录像的全部的二进制代码,你想想有多困难?就算专门做录像分析的SC2Gear也只支持过0.11之后的全部opcode,之前的他也没有解。但是管家做到了,而且告诉大家一个好消息,新版本的opcode已经解出了50%以上了。

     再说地图,也分为了0.2-0.10版本,0.11-0.14.1版本,0.16-0.18版本,0.19-0.21,1.0-1.0.3版本的版本的区别,特别是0.18以下地图的黄金矿和了望塔,0.19以上的星际2全部不支持,只有管家让他们兼容了,谁做谁知道多么苦痛。

     还有录像回放、网关切换、地图编辑、单机游戏、目录变化的兼容,真的是一言难尽。

    不是说大家不能提bug,大家有意见可以直接问我,我基本有问必有答的,大家现在也知道我处境很难,被一些商业媒体到处赶,你们可能不明白的被5毛党们一渲染,仿佛成了管家的大问题,因此希望大家遇到问题即使到我论坛沟通,不要随便发贴,我很少上其他论坛的,只有我师弟偶尔看到才会告诉我。

    说了一大通无用的话,下面解释一下标题问题的原因,不然我就成了标题党了,^_^,这个原因就是暴雪改了存盘文件Sc2Save文件的格式,将序列做了大调整,为了他自己编程的方便,就不兼容以前的Sc2Save文件了,要读以前的文件,请找以前的版本。(我做梦都想不兼容多好,大家保留星际管家的n个版本,用那个版本对应那个版本,^_^)。

    原因找到了,解决办法就找到了,读以前剧情的存盘,请用1.0.0.16117或者1.0.3.16389加载即可继续玩,因为其他工具都只支持16117,因此他们都兼容以前战役,而不支持现在的战役。

   新版星际管家下载地址:http://www.ucbug.com/html/youxifuzhu/xg/2010/0926/4427.html

声明:本站所有资源均来自网络,版权归原公司及个人所有。如有版权问题,请及时与我们联系,我们在第一时间予以删除,谢谢!
ucbug游戏网
关于我们 | 下载帮助 | 广告&合作 | 下载声明 | 版权声明
Copyright © 2010-2016 ucbug.com. All Rights Reserved ucbug游戏网
皖ICP备15003425号 适度游戏娱乐,沉迷游戏伤身。